Version 2.5
(Excel 2010[footnoteRef:1]) [1:  The procedures will be similar for any version of Excel from 2007 onwards (i.e. those versions which have  tabs).  The corresponding procedures for earlier versions (those which use Char t Wizard) are available on request.] 


Graphs and charts in Microsoft Excel – an overview by Mike Griffiths

Contents

1	Notes on Style	1
2	Overview of Excel	2
3	Creating a default graph in Excel	2
4	Formatting, and other changes to graphs	5
5	Changing the data source altogether	8
6	Copying graphs to Word documents (etc)	8
7	More than one data series on the same scale	9
8	Combination graphs (e.g. more than one data series on different scales)	9
9	More than one data series/independent variable: bar charts	11
10	Error bars	11
11	Histograms	12
12	Survey results	15


[bookmark: _Toc378578410]Notes on Style

This document is intended as a guide to techniques in Excel, rather than as a style guide.  Therefore, the illustrations do not necessarily show graphs that are finished ready for publication.

All publishers, and markers of student work, will have certain expectations of a finished graph, e.g.
· All axes should be clearly labelled
· Units should be shown.

For historical reasons, tables and figures are usually considered to be two separate series within a document.  
· Tables are made up of words and numbers, which a typesetter would have been able to set up.  They are labelled Table xxx, starting at 1 with the first table and going up in order.  After the table number there should be a caption, explaining what the table shows.  Table numbers and captions go above the table they refer to.
· Figures are graphs or other illustrations, which would have had to be given to the type setter on a metal plate to be inserted into the document.  They are labelled Figure xxx, starting at 1 with the first figure and going up in order.  After the figure number there should be a caption, explaining what the figure shows.  Figure numbers and captions go below the figure they refer to.  Therefore, it is usually easier to add them in your word processor, rather than in Excel.

For more details on the style that is needed for your graphs (or the rest of your document) refer to the style guide issued by your publisher, or in the case of students any instructions given by your instructor.  (For psychologists, the ultimate authority is likely to be the latest version of the Publication Manual of the American Psychological Association).


[bookmark: _Toc378578411]Overview of Excel

Excel is a versatile tool for calculation and data manipulation.  However, this document focusses on another of its strengths – graphs.  It is very versatile in this area too, featuring a wide range of graph types whose formats can be changed in all sorts of ways.  Note that Excel calls graphs ‘charts’, and I will often use the terms interchangeably.

A useful feature of Excel is that (by and large) it is dynamic.  That is to say, if you change a number on the sheet, Excel will automatically change anything that is calculated from that number.  That includes graphs.  

Like most programmes, Excel has an ‘undo’ facility.  Click on the Undo button at the top of the screen, third from the left ().  Notice the little arrow at the right of the button – if you click on this you can go back and undo several commands at once.Nonetheless, if you are making changes to a worksheet (or any other document) think about whether you might want to revert to an earlier version.  If so, save it under a different name – often the best method of naming is to use version numbers such as v1, v2 etc.

[bookmark: _GoBack]Finally, remember that a good way to learn about this sort of programme is to experiment!  (If you are doing so with important data, do remember to keep a backup copy of your file under a different name.)   As we go along, you will notice lots of options and facilities that I don’t mention.  With graphs in Excel, the biggest constraint is thinking of what you want to do.  If you can imagine it, there is usually a way of doing it.


[bookmark: _Ref366420545][bookmark: _Ref366420961][bookmark: _Toc378578412]Creating a default graph in Excel

Suppose that we want to print a graph of rainfall data over several months.  Open Excel and enter the data, as in Figure 1.

Highlight the data, including the titles (e.g. by clicking on the top left hand cell, holding down the left mouse button, moving to the bottom right cell and releasing).  Go to the Insert tab and find the Charts section (the third one along).  Above the word Charts there are icons of various different charts.  Hover the mouse above them and they give more information, or left-click and they give a range of subtypes.  Click on Column and choose the first subtype and straight away you will get the chart in Figure 2.  Notice that this is called a ‘column chart’ in Excel, which reserves the name ‘bar chart’ for one in which the bars are horizontal.



[bookmark: _Ref366420301]Figure 1: Sample data for basic graphs

You can repeat this, but choosing other graph types from their icons.  Some of the other basic graphs you can create are shown in Figure 3.  

Notice that whenever you create a graph, a new set of tabs (Chart Tools) appear at the top.  They also appear whenever you click on the chart to select it.  These provide some of the ways of making changes to your graph.  We will cover this in section 4.

[bookmark: _Ref366420327]Figure 2:  Default column chart for the data in Figure 1

	
	

	(a) line chart
	(b) pie chart


[bookmark: _Ref366420339]Figure 3:Some other default charts from the data in Figure 1

Another common kind of graph is a scatterplot.  Suppose you had collected the data I in Figure 4, and you wanted to plot one variable against the other.  Select the data on the Excel spreadsheet (including the headings), go to the Insert tab and the Charts section, and choose the Scatter icon.  The output from the first option is shown in Figure 5.  It illustrates each of the cases in the data: for example, the extreme left point shows that the person who studied for 0 hours scored 5 on the test.

It is simple to add a trend line.  With the graph highlighted, click on the Layout tab, and then on Trendline (in the Analysis section).  Select the trend line you want (usually Linear, the second option).  The chart should now look like Figure 6.

	

	


	
[bookmark: _Ref366420374]Figure 4: data for scatterplot
	[bookmark: _Ref366420426]Figure 5:default output for data in figure 4.




[bookmark: _Ref366420409]Figure 6:  the chart from Figure 5after adding a default trend line


[bookmark: _Ref366415856][bookmark: _Toc378578413]Formatting, and other changes to graphs

Some of the changes described below are illustrated in Figure 7.


[bookmark: _Ref366420514]Figure 7:  Figure 2 after editing


Moving and resizing

You can easily move the graph around the spreadsheet.  Left-click with the mouse on the white area, then move the mouse with the button held down (i.e. ‘drag’ the graph).  Obviously you can make more major moves (e.g. onto a different worksheet) by cutting and pasting.

You can resize the graph by hovering the mouse above one of the corners so that the cursor becomes a double ended, slanting arrow.  Hold down the left mouse button and drag the chart.  Depending on the direction you drag, you can either maintain the existing proportions or stretch (or reduce) the chart horizontally or vertically.

Changes in the source data

You can change some aspects of the graph just by changing the original data in the spreadsheet.  For example, on the graphs in section 2 you could change ‘inches’ to ‘feet’, ‘June’ to ‘Jul’, or the numbers; and of these will be reflected straight away on the graph.

Formatting in general; selecting parts of the chart

Most other formatting is initiated by one of the following means.  (Usually, there is more than one possible way of doing it).
· Select the graph (by left-clicking on the white area) and use the Chart Tools tabs which appear at the top.  Notice that if the action applies to only part of the chart, Excel will guess which part it applies to, for example the part that is selected.  If you want to change this, you can use the drop-down box at the top left of the Layout or Format tabs.
· Hover the mouse over the part of the graph you want to change, so that the screen tip (the words that appear in a little box) name that part of the graph.  Double click, or right click.  Usually, double-clicking will bring up a dialogue box relevant to that feature of the graph; right-clicking will bring up a drop-down menu which includes a link to the same dialogue box and additional options such as deleting the feature altogether.

(Note:  If you wish, you can single-click on an item first in order to select it.  Notice that if you single-click on an item such as a bar once, you select all of the bars in the series.  If you click again, you select just that bar.)

Deleting features of the graph

For example, if you right-click on the ‘legend’ (the word ‘inches’ on the right of the graph) you can then click on Delete.  (Excel automatically re-sizes the rest of the chart to use the space this releases.)

You might also want to remove the horizontal lines.  Hover the mouse so that the screen tip reads Vertical (Value) Axis Major Gridlines, right click, and choose Delete.


Colours, typefaces, line formats and markers, fillings of bars and columns

To change the typeface, font size or colour of any of the wording, click on it and go to the Home tab.  You can then use the Font section in the normal manner.  For example, I have changed the title to red.  

Similarly, to colour in a part of the graph such as the Plot Area you can select it, then use the Colour icon on the Home tab.  The other parts of the Font section are greyed out in this instance.

Rather than colour the graph in, you might want to remove all of the colour, for example to put it into a black-and-white report.  Double-click on the item concerned, for example on the bars in a bar chart.  To simply make the bar black, you can make the appropriate selection under Chart Stylesin the Design tab.  For more sophisticated fills, double-click to bring up the Format Data Point dialogue box, choose Fill and Pattern Fill, and choose from the options that come up.  If you want the fill to be black-and-white, choose these as the Foreground Color and Background Color.

You can change the format of the line in a line graph in a similar fashion, e.g. change or remove the colour of the lines, or change the line from solid to dotted.  For example to make a dotted line, double-click on the line.  Click Line Style and change the Dash type.  In the same dialogue box, under Marker Options you can insert markers for each data point, and specify their style and size. 

Adding, removing or changing titles and legends

Some titles can be changed simply by clicking on them, then typing in the changed wording that you want.(For example, you could change the title at the top to ‘Rainfall in Metown’.)  However, the most comprehensive facility for adding or removing titles and axis labels is to select the graph, bringing up the Chart Tools tabs.  Under Layout there is a whole array of icons in the sections labelled Labels and Axes.  For example, if you click on Axis Titles, then Primary Vertical Axis Title, you could choose Rotated Title.  Delete the default wording and insert ‘Inches’.

Chart axes

Various changes can be made to the axes of the graph.  For example, to change the vertical axis, hover the mouse so that the screen tip reads Vertical (Value) Axis.  Double-click.  UnderAxis Options, you can change the minimum and maximum values, and change the intervals of the figures on the graph.  For example, to show only whole inches, change Major Unit from Auto to Fixed, and the unit to 1.It will automatically change the number of decimal places to zero, but you could have done this by hand in the same dialogue box.  Choose Number from the options on the left, under Category select the Number category, and in the box that appears on the left type in the number of decimal places you want.  

You may find that not all of the description you need (e.g. names of the months in this example) is shown on the axes, especially if you have reduced the size of the graph.  This can usually be cured by reducing the font size.  Alternatively you can bring up the Format Axis dialogue box and under Alignment you could for example change the Text Direction.  Or you could increase the size of the graph to make more room (see ‘Moving and Resizing’ above).

If your axis is expressed in very large units (e.g. millions) you can instruct Excel to show this.  See section 9 for an example.


[bookmark: _Toc378578414]Changing the data source altogether

Sometimes you might want to change the data source.  For example, if you have created a graph that you like, you might want to copy it and use exactly the same format for a different set of data.  The data must occupy an area of the spreadsheet the same size and shape as the original data.

Select the graph (e.g. by clicking on the white area).  In the Design tab, click on Select Data.  In the dialogue box that comes up, click on the icon on the right hand side of the Chart Data Range box.  This takes you back to the data sheet.  Choose the data range you want and hit Enter.  Click OK.

Also on the Chart Tools tab there is an icon to Switch Row/Column if Excel has incorrectly guessed which way round you want the graph.  (This is most likely to be relevant to the type of graph in section 9.  As discussed there, there is also a more direct way of doing this.)


[bookmark: _Toc378578415]Copying graphs to Word documents (etc)

Copying a graph into a Word document is usually straightforward:
· Right click on the Excel graph and choose Copy (or go to the Home tab and select the Copy icon).
· Open Word, and in the Home tab choose the Paste icon.

Notice that in Office 2010, the copied chart remains open to some editing.  If you wish to avoid this, instead of Paste choose Paste Special (from the drop-down menu under the Paste icon), and Picture, Advanced Metafile.  This also makes it easier to obtain the Picture Format dialogue box (by right-clicking on the picture).

In general, if you have problems copying objects from one programme to another:
· Look out for any Copy Special options that might exist in the first programme
· Try out the Paste Special options in the second programme
· In the last resort, try copying via a third programme (e.g. from Excel to Powerpoint then Powerpoint to Word).


[bookmark: _Toc378578416]More than one data series on the same scale

Creating a line graph with more than one data series is much the same as when there is only one.  If you have entered and select the data in Figure 8, you can click the Insert tab, thenselect a line graph.  The default output is shown in Figure 9.


[bookmark: _Ref366420670]Figure 8:  data for figure 9


Having created such a graph, you can select and edit each data series (e.g. each line on the above graph) separately.


[bookmark: _Ref366420679]Figure 9: Default line chart for the data in figure 8


[bookmark: _Ref366417809][bookmark: _Toc378578417]Combination graphs (e.g. more than one data series on different scales)

Suppose you wanted to present the data in Figure 10, where the two data series represent different variables.  You might want to emphasise this by showing them in different ways, as in Figure 11.  Select the data.  Go to the Inserttab and the Charts section as usual.  Select (for example) the Line icon and the first option.  

This produces a graph, but the Hrs sun are hardly showing – they are flat along the bottom.  Double-click this line, and under Series Options move it from the Primary Axis to the Secondary Axis.  

Both lines are now visible.  (The newly created secondary axis, on the right, is automatically of an appropriate scale for the values it relates to.)  However you might want Hrs sun to be shown in bars (as in my specimen), to make the graph clearer.  Right-click on the data series and choose Change Series Chart Type.  Select Column.  Your chart should now look like Figure 11.  Remember that you will need to explain somewhere which axis relates to which data!


[bookmark: _Ref366420718]Figure 10:  Data for combination chart (Figure 11)


[bookmark: _Ref366420702]Figure 11: Combination chart


[bookmark: _Ref366152592][bookmark: _Toc378578418]
More than one data series/independent variable: bar charts

If you want a bar chart for the kind of data shown in Figure 13, you follow a similar process to that for a simple bar chart.  If you simply select the cells A1:C4, go to the Insert tab and select the default Bar chart, you will get the chart shown in Figure 13(a).  

Excel will guess which way round the chart is to be displayed, but sometimes you want the opposite, as in Figure 13(b).  With the chart selected, choose the Design tab, and Switch Row/Column.


Figure 12:  Data for the charts in figure 11.  (Source: 2011 Census.)

	
	

	(a) default
	(b) transposed


[bookmark: _Ref366420780]Figure 13: Two way bar charts

Incidentally, notice another change I made in Figure 13(b).  I right-clicked on the Vertical (Value) Axis, selected Format Axis, and under Axis Options, I clicked on the Display Units box and changed it from None to Millions.


[bookmark: _Toc378578419]Error bars

Beware:  if you use Excel’s options to calculate error bars, you are liable to get the wrong figures.  Instead, enter them manually.  Suppose we want to display the means and error bars as in Figure 14.


[bookmark: _Ref366420848]Figure 14: Example data for error bar chart

First, select the data, without including the error bar information (in this case, the condition and score information).  Go to the Insert tab and choose a graph (I have selected the default Column chart).  Click on the bars to select them.  In the Layout tab, select Error Bars (in the Analysis section).  Click on More Error Bars options, at the bottom.  Choose Custom.  Click the Specify Value button.   For Positive Value, click on the icon at the right so that you can point to the sheet, and select from there the range of values containing the figures you want for positive error bars (for all the data points).  Press Enter on the keyboard.  Do the same for the negative error bars.  The result is shown in Figure 15.


[bookmark: _Ref366420864]Figure 15:Example graph with error bars

Obviously, Excel does not include an explanation of what these bars represent.  They are commonly used to show Standard Deviations, Standard Errors, and 95% Confidence Intervals.  So be sure to explain which they are, somewhere on the chart or caption.


[bookmark: _Toc378578420]Histograms

Histograms are hard work in Excel.  I will demonstrate two different methods.  One of these uses the Analysis ToolPak, which is not part of the default installation of Excel and has to be installed separately.  (If it is already installed, you will have an icon on the right hand side of yourData tab, labelledData Analysis.)

Suppose you wanted a histogram of the data in Figure 16, in the columns headed ‘Score’.


[bookmark: _Ref366420893]Figure 16:  Data and workings for a histogram

Step 1.

In either case, you need to decide the bins that you want the data put into.  (If you have the Analysis ToolPak, Excel can decide the bins, but I do not recommend this method is because of its inflexibility.)  

I have entered bin boundaries alongside the data in Figure 16, in the column headed ‘Bins’.  Remember that for your histogram to be valid, you should ensure that the bins are of equal sizes, i.e. the numbers you type in should be in equal sized steps.

In the eventual chart there will be one more category than your bin boundaries.  The first category will be everything up to the lowest boundary; the next will be between the lowest and the second lowest; and so on up until the final category which is everything above the highest boundary.  Put labels against the bin boundaries showing this (as I have); they will be needed later.

Step 2A (with the Analysis ToolPak).

In the Data tab, click the Data Analysis icon.  From the drop-down list, choose Histogram.

In the dialogue box that comes up:
· Enter the data range (for just that one variable, i.e. in this case, just the Scores) intoInput Range.
· Enter the range where you have typed bins intoBin Range.
· If these ranges include headings (although there appears to be no benefit from including them!), tick the Labels box.  Otherwise, leave this box blank.
· Choose where you want the output.  If you want it on the same sheet, click Output Range and enter the cell where you want the output to start.  Alternatively, choose the appropriate option to put it in a new worksheet or workbook.  In making your choice, note that SPSS will be creating a new table of figures as well as the chart.
· You also need to click Chart Output.

To my mind, the labels on the x-axis are misleading.  They give the value for the bottom of each range, rather than the middle.  To correct this, select the graph.  In the Design tab, click on the Select Data icon.In the dialogue box, in the Horizontal (Category) Axis Labels section, click on the Edit button.   Replace the range with the one for the labels you created manually in step 1.

Now go to step 3.

Step 2B (without the Analysis TookPak)

We need to use what is called an ‘array formula’.  Select the cells immediately to the right of the labels you created in step 1.  (For example, if the labels are in cells E2:E9, select F2:F9).  Click on the formula bar (the white area to the right of the  symbol near the top of the screen).  Enter a formula in this format: ‘=frequency(B2:B13,D2:D8)’, where B2:B13 is the cell range where the data are, and D2:D8 is the cell range where the bin values are..  Instead of simply hitting Enter, hold down Control and Shift together whilst doing so.  The results (i.e. the number of scores in each bin) should appear in the cells you selected.

Now select these results, together with your labels (in this case, E2:E9).  Create a column chart (see section2).

Step 3.

You have an unwanted legend on the right hand side of the chart (probably ‘frequency’ or ‘series1’) depending on which method you used in Step 2.  Right-click and delete it.

For a histogram, the columns are supposed to touch each other.  Double-click on the columns to bring up the Format Data Series dialogue box.  In Series Options, move the slider for Gap Width all the way to the left, i.e. No Gap; 0%.

Now of course you cannot see the edges of the columns.  If you like a modern style of presentation you might be happy with this, but if not:
· While still in Format Data Series (or bringing it back up[footnoteRef:2]), go to Border Color and change it to Solid Line.  Change the Color to black. [2:  Remember, if you have just selected the columns and you select them again, you might find you have selected just one.  If necessary, click on a different chart feature and come back, to make sure you select all of them.] 

· Also in Format Data Series, go to Fill and select Solid Fill.  Under Fill Color choose a light colour, such as a grey.
· Alternatively under Fill, you could choose a Pattern Fill.  If you want the result to be black and white, remember to select black as the Foreground Color and white as the Background Color.

Finally, you may want to re-size the graph or to change its shape.  Also, you might like to review the number format and Major Unit on the vertical axis; remember that frequencies can only be whole numbers, so there is no point in showing any decimals! You will probably also want to add some labels to the axes.

My final version is shown in Figure 17.


[bookmark: _Ref366420996]Figure 17: Histogram created in Excel


[bookmark: _Toc378578421]Survey results

A format I have used for survey results is shown in Figure 18.

To create this, the data were first entered as in Figure 19.  Note that the full contents of the cells have been revealed by selecting them and clicking on Format – Cells – Alignment and selecting Wrap text.  I have done this in order to make it easier to see what I have done – it is not essential to do this to create the graph.


[bookmark: _Ref366421012]Figure 18:  Responses by percentage to questions in a survey




[bookmark: _Ref369617803]Figure 19:  Data for Figure 18

The data, including row and column headings, were selected.  Under the Insert tab, Charts section, I chose the Bar icon.  Under 2-D bar, I selected the third option, 100% stacked bar.

On the chart that Excel created, I first moved the legend from the right hand side to the bottom, by double-clicking to bring up the Format Legend dialogue box and choosing Bottom for the Legend Position.  Back in the chart, I selected the legend in its new position and re-sized it to take up the whole width of the chart (by selecting it and using the handles on its own separate box).

I then changed the colours so that they went in a logical order, using black and white only.  Firstly I chose each data series in turn by double-clicking on it.  (“Data series here means “agree” for all questions, “tend to agree” for all questions, etc.)  In the Format Data Point dialogue box, I clicked Fill, followed by Solid Fill or Pattern Fill as required.  I chose black, white, and/or grey as colours as required.  (If creating a colour graph, obviously you would choose appropriate colours instead.)   Where necessary, I went to Border Color and changed the setting from Automatic to Solid line, making sure that the Color was black.

Also in the Data Point dialogue box, under Series Options, I reduced the Gap Width so that there was more space for the fillings of the bars to show up.

Then I went to the Layout tab and inserted a Chart Title(using the third option, to resize the chart accordingly).  In this case I had to make two changes as knock-on effects of Excel finding room for the title.  I had to resize the graph (to make room for the row captions which Excel had removed), and move the caption, which overlapped with the main body of the chart.  

Obviously in general you may find it necessary to change the size of the graph, and/or the font size of individual features, to suit your requirements.


Note: I will be happy to receive questions, comments and corrections on this document, including how to do things not included above.

Mike Griffiths (mike_g50@hotmail.com), September 2013
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